2) Напишите программу, которая в последовательности случайных чисел определяет количество простых чисел. Программа получает на вход количество чисел в последовательности, а затем – сами числа.
Написать на C++
Ответы на вопрос
Ответил leonidkorolev2007
0
Ответ:
#include <iostream>
#include <vector>
using namespace std;
bool f(int n) {
for (int i = 2; i <= sqrt(n); i++)
if (n % i == 0)
return false;
return true;
}
int main() {
int n,sum=0;
cin >> n;//кол. числе в последовательности
vector<int> m(n);//создаем вектор с кол. элементов n
for (auto& v : m) {
cin >> v;//заполняем элементы числами
if (f(v)) sum++;//проверим что число простое и если простое то увеличим счетчик на единицу
}
cout << endl << sum;//вывод количества просты чисел
}
Подробнее - на Znanija.com - https://znanija.com/task/34551760#readmore
Объяснение:
Новые вопросы
Русский язык,
2 года назад
Українська мова,
2 года назад
География,
7 лет назад
Геометрия,
7 лет назад
Физика,
9 лет назад