Информатика, вопрос задал vlad66666v , 1 год назад

2. Напишите программу, которая работает с данными о продуктах и их ценах. Пользователь будет вводить название продукта и его цену через запятую. Программа должна сохранять эти данные в словаре, где название продукта будет ключом, а цена - значением. Затем программа должна отсортировать словарь по возрастанию цены и вывести результат на экран.

Ответы на вопрос

Ответил andreyfedyanovich
0

python
products = {}

while True:

   input_str = input("Enter product name and price separated by comma (or 'done' to finish): ")

   if input_str == 'done':

       break

   name, price = input_str.split(',')

   products[name.strip()] = float(price)

sorted_products = sorted(products.items(), key=lambda x: x[1])

for name, price in sorted_products:

   print(f"{name}: {price:.2f}")
Прости я не могу к сожелению на руском надеюсь помог:D


kamenkovaanastasia95: Помоги пожалуйста с последним заданием в профиле по информатике
Новые вопросы