Информатика, вопрос задал MineStar , 1 год назад

2 *. Написать программу «Банк». Вводится сумма вклада и количество лет. Рассчитать сколько денег будет на счету пользователя к концу времени вклада. Решить задачу по системе «сложный процент» (процент рассчитывается от новой суммы) Годовой процент считать равным 10%.

3. Задача «Лесенка»
По данному натуральному n ≤ 9 выведите лесенку из n ступенек, i-я ступенька состоит из чисел от 1 до i без пробелов.
1
1 2
1 2 3
1 2 3 4

4 *. Напишите программу для отображения только тех чисел из списка, которые удовлетворяют следующим условиям
Число должно делиться на пять
Если число больше 150, пропустите его и перейдите к следующему числу.
Если число больше 500, остановите цикл
Пример
Дано :
numbers = [12, 75, 150, 180, 145, 525, 50]
Ожидаемый результат:
75
150
145

5 **. Последовательность Фибоначчи - это серия чисел. Следующее число находится путем сложения двух чисел перед ним. В первые два числа 0 и 1.
Например, 0, 1, 1, 2, 3, 5, 8, 13, 21. Следующее число в этой серии выше - 13 + 21 = 34.

Ожидаемый результат:
Последовательность Фибоначчи:
0 1 1 2 3 5 8 13 21 34

Ответы на вопрос

Ответил anastsiadonets2005
0

Ответ:

2.def calculate_amount(deposit, years):

   interest_rate = 0.1  # 10% річних

   total_amount = deposit * (1 + interest_rate) ** years

   return total_amount

deposit = float(input("Введіть суму вкладу: "))

years = int(input("Введіть кількість років: "))

final_amount = calculate_amount(deposit, years)

print("Сума на вашому рахунку після", years, "років:", final_amount)

3.n = int(input("Введіть кількість ступенек: "))

for i in range(1, n + 1):

   for j in range(1, i + 1):

       print(j, end=" ")

   print()

4.numbers = [12, 75, 150, 180, 145, 525, 50]

for num in numbers:

   if num > 500:

       break  # Зупиняємо цикл, якщо число більше 500

   if num > 150:

       continue  # Переходимо до наступної ітерації циклу, якщо число більше 150

   if num % 5 == 0:

       print(num)

5.def fibonacci_sequence(n):

   sequence = [0, 1]

   for i in range(2, n):

       next_num = sequence[i-1] + sequence[i-2]

       sequence.append(next_num)

   return sequence

n = int(input("Введіть кількість чисел Фібоначчі: "))

fib_sequence = fibonacci_sequence(n)

print("Послідовність Фібоначчі:")

for num in fib_sequence:

   print(num, end=" ")

Новые вопросы