Информатика, вопрос задал romabarnashov45 , 7 лет назад

2 курс, основы алгоритмизации и программирования, помогите!!!

Нужно построить программный код по задаче на языке c#:

Составить программу вычисления максимального значения функции y=x^2-3x+lnx при изменении аргумента x в интервале 1<=x<=5 с шагом 0.5​

Ответы на вопрос

Ответил excalibur312craft
0

Ответ:

           double [] arr =new double [13];

           int i = 0;

           for (double x = 0; x <= 6; x += 0.5)

           {

               arr[i] = Math.Log(x + 3.7) * Math.Cos(x);

               i+=1;

           }

           double min = arr.Min();

           Console.WriteLine("Min = {0}",min);

           Console.ReadKey();

Объяснение:

Новые вопросы