2. Дан текстовый файл. Напишите программу, в которой считывается информация построчно и вызывается функция, подсчитывающая количество слов в строке, которые совпадают с первым словом.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!
function LexRepeat(Self:string):(string,integer); extensionmethod;
begin
Writeln(Self);
var aw:=Self.MatchValues('bw+b').ToArray;
if aw.Count>1 then
Result:=(aw[0],aw[1:].Where(w->LowerCase(w)=LowerCase(aw[0])).Count)
else Result:=(aw[0],0)
end;
begin
ReadLines('Pushkin2.txt').Select(s->s.LexRepeat)
.Where(x->x[1]>0).Foreach(x->Writeln('*** ',x[0],' - ',x[1]+1,' ***'))
end.
Пример работы программы
Александр Пушкин
К***
Я помню чудное мгновенье:
Передо мной явилась ты,
Как мимолетное виденье,
Как гений чистой красоты.
В томленьях грусти безнадежной,
В тревогах шумной суеты,
Звучал мне долго голос нежный
И снились милые черты.
Шли годы. Бурь порыв мятежный
Рассеял прежние мечты,
И я забыл твой голос нежный,
Твои небесные черты.
В глуши, во мраке заточенья
Тянулись тихо дни мои
Без божества, без вдохновенья,
*** Без - 2 ***
Без слез, без жизни, без любви.
*** Без - 3 ***
Душе настало пробужденье:
И вот опять явилась ты,
Как мимолетное виденье,
Как гений чистой красоты.
И сердце бьется в упоенье,
И для него воскресли вновь
И божество, и вдохновенье,
*** И - 2 ***
И жизнь, и слезы, и любовь.
*** И - 3 ***
Во вложении - исходный файл Puskin2.txt
// Внимание! Если программа не работает, обновите версию!
function LexRepeat(Self:string):(string,integer); extensionmethod;
begin
Writeln(Self);
var aw:=Self.MatchValues('bw+b').ToArray;
if aw.Count>1 then
Result:=(aw[0],aw[1:].Where(w->LowerCase(w)=LowerCase(aw[0])).Count)
else Result:=(aw[0],0)
end;
begin
ReadLines('Pushkin2.txt').Select(s->s.LexRepeat)
.Where(x->x[1]>0).Foreach(x->Writeln('*** ',x[0],' - ',x[1]+1,' ***'))
end.
Пример работы программы
Александр Пушкин
К***
Я помню чудное мгновенье:
Передо мной явилась ты,
Как мимолетное виденье,
Как гений чистой красоты.
В томленьях грусти безнадежной,
В тревогах шумной суеты,
Звучал мне долго голос нежный
И снились милые черты.
Шли годы. Бурь порыв мятежный
Рассеял прежние мечты,
И я забыл твой голос нежный,
Твои небесные черты.
В глуши, во мраке заточенья
Тянулись тихо дни мои
Без божества, без вдохновенья,
*** Без - 2 ***
Без слез, без жизни, без любви.
*** Без - 3 ***
Душе настало пробужденье:
И вот опять явилась ты,
Как мимолетное виденье,
Как гений чистой красоты.
И сердце бьется в упоенье,
И для него воскресли вновь
И божество, и вдохновенье,
*** И - 2 ***
И жизнь, и слезы, и любовь.
*** И - 3 ***
Во вложении - исходный файл Puskin2.txt
Приложения:
Ответил Monokumi4
0
В языке СИ
Ответил Аноним
0
Поздно пить "Боржоми"... в задании не был указан язык программирования. Что говорит нам о том, что Вам на чужой труд попросту наплевать.
Ответил Аноним
0
Посмеюсь, если кто-то соберется на С это написать - будет длиннее разика в три. Или в пять... ))
Новые вопросы