1составьте программу ,вычисляющую сумму кубов первых n натуральных чисел
2Туристы в 1-ый день прошли 7км.В каждый следующий день они проходили на 1.5 км > .Составь программу ,вычисляющую сколько километров они пройдут за n дней.
Помогите срочно ,пожалуйста )))
Ответы на вопрос
Ответил PuerDeSatan
0
1
const
n = 100;
var
a: array[1..n] of word;
i, m: byte;
sum: word;
begin
write('Kol-vo chisel: ');
readln(m);
sum:=0;
for i:=1 to m do
begin
a[i] := i;
write(a[i]:4);
sum:=sum + sqr(a[i])*a[i];
end;
writeln;
writeln('Sum = ', sum:4);
readln;
end.
2
const
n = 100;
var
a: array[1..n] of word;
i, dn: byte;
km: real;
begin
write('Kol-vo dney: ');
readln(dn);
km:=7;
for i:=2 to dn do
km:=km+(km+1.5);
writeln;
writeln('Turisty proshli ', km:4:1, ' km');
readln;
end.
const
n = 100;
var
a: array[1..n] of word;
i, m: byte;
sum: word;
begin
write('Kol-vo chisel: ');
readln(m);
sum:=0;
for i:=1 to m do
begin
a[i] := i;
write(a[i]:4);
sum:=sum + sqr(a[i])*a[i];
end;
writeln;
writeln('Sum = ', sum:4);
readln;
end.
2
const
n = 100;
var
a: array[1..n] of word;
i, dn: byte;
km: real;
begin
write('Kol-vo dney: ');
readln(dn);
km:=7;
for i:=2 to dn do
km:=km+(km+1.5);
writeln;
writeln('Turisty proshli ', km:4:1, ' km');
readln;
end.
Новые вопросы