19 баллов! Написать программу для паскаля. С клавиатуры вводятся два натуральных числа (n и m. Число n меньшее). Вывести на экран все числа от n до m сумма цифр которых равна 12
Ответы на вопрос
Ответил Аноним
0
Var
n,m,A,S:integer;
Begin
Write('n = ');ReadLn(n);
Write('m = ');ReadLn(m);
For m:= n to m do
Begin
S:=0;
A:=m;
While A > 0 do
Begin
S:=S+A mod 10;
A:=A div 10
End;
if S = 12 then Write(m,' ')
End;
End.
n,m,A,S:integer;
Begin
Write('n = ');ReadLn(n);
Write('m = ');ReadLn(m);
For m:= n to m do
Begin
S:=0;
A:=m;
While A > 0 do
Begin
S:=S+A mod 10;
A:=A div 10
End;
if S = 12 then Write(m,' ')
End;
End.
Новые вопросы