17. Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.
Ответы на вопрос
Ответил AnonimusPro
0
Program n1;
var sum,a: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if(a=3) or (a=6) or (a=9) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
var sum,a: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if(a=3) or (a=6) or (a=9) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
Новые вопросы
История,
2 года назад
Українська мова,
2 года назад
Математика,
8 лет назад
Биология,
8 лет назад
Математика,
9 лет назад