Информатика, вопрос задал asmirakaush , 1 год назад

16. Напишите программу, которая запрашивает у пользователя число и проверяет, является ли оно простым или составным. Если число простое, программа должна вывести сообщение "Число простое", а если составное - "Число составное".​

Ответы на вопрос

Ответил Anigoo1
0

Ответ:

Для проверки числа на простоту, необходимо проверить, есть ли у числа множители, отличные от единицы и самого числа. Если такие множители есть, то число составное, иначе - простое.

=-| PYTHON |-=

number = int(input("Введите число: "))

if number > 1:

   for i in range(2, number):

       if number % i == 0:

           print("Число составное")

           break

   else:

       print("Число простое")

else:

   print("Число должно быть больше 1")

=-| END |-=

На первой строке мы запрашиваем у пользователя число и преобразуем его к целочисленному типу.

Затем мы проверяем, что число больше 1, так как 1 не является простым или составным числом.

Если же число оказалось меньше или равным 1, то мы выводим сообщение о том, что число должно быть больше 1.

Объяснение:

Ответил akbe2020
0

//Java

import java.util.ArrayList;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner scanner = new Scanner(System.in);

       System.out.print("Введите число ");

       int maxRange = scanner.nextInt();

       ArrayList<Integer> primeNumbers = new ArrayList<>();

       primeNumbers.add(2);

       boolean canBeDivided = false;

       for (int i = 2; i <= maxRange; i++) {

           for (int j = 0; j < primeNumbers.size(); j++) {

               if (i % primeNumbers.get(j) == 0) {

                   canBeDivided = true;

                   break;

               } else {

                   canBeDivided = false;

               }

           }

           if (!canBeDivided) {

               primeNumbers.add(i);

           }

       }

       if(primeNumbers.contains(maxRange)) {

           System.out.println("Число простое");

       } else {

           System.out.println("Число составное");

       }

   }

}

Новые вопросы