№109.
Написать программу, которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее арифметическое.Рекомендуемый вид экрана во время работы программы приведен ниже. Данные, введенные пользователем выделены полужирным шрифтом.Вычисление среднего арифмитического последовательности дробных чисел. После ввода каждого числа нажимайте .
-> 5.4
->7.8
-> 3.0
-> 1.5
-> 2.3
Среднее арифмитическое введенной последовательности: 4. 00
Для завершения работы программы нажмите < Enter>.
Ответы на вопрос
Ответил arseney0cs
0
#include <iostream>
using std::cin, std::cout, std::endl;
int main(){
long double sum = 0;
for(size_t i = 0;i<5; ++i){
cout << "-> ";
double a;
cin >> a;
sum+=a;
}
cout << sum/5 << endl;
return 0;
}
Но не вовсем понятно, что нужно делать после ввода каждого числа, я написал, что нужно вводить <Enter> после каждого
Ответил arseney0cs
0
пордон, надо была на паскале
Ответил arseney0cs
0
var i: integer;
var a : array[1..5] of real;
begin
for i in [1..5] do
begin
writeln('->');
readln(a[i]);
end;
writeln((a[1]+a[2]+a[3]+a[4]+a[5])/5:0:2);
end.
var a : array[1..5] of real;
begin
for i in [1..5] do
begin
writeln('->');
readln(a[i]);
end;
writeln((a[1]+a[2]+a[3]+a[4]+a[5])/5:0:2);
end.
Новые вопросы
Другие предметы,
2 года назад
Қазақ тiлi,
2 года назад
Алгебра,
7 лет назад
Алгебра,
7 лет назад
Математика,
9 лет назад