Информатика, вопрос задал Аноним , 7 лет назад

100 БАЛЛОВ!!! ЯЗЫК СИ, НЕ СИ++!!!
Написать программу, выводящую на экран таблицу умножения. Код программы должен содержать внешнюю рекурсивную функцию.

Ответы на вопрос

Ответил Omikami
1

#include <stdio.h>

void func(int i)

{

   if(i < 1 || i > 10) return;

   for(int ix = 1; ix <= 10; ++ix)

   {

       printf("%i x %i = %i\t", i, ix, i * ix);

   }

   printf("\n");

   func(i + 1);

}

int main()

{

   func(1);

   return 0;

}

Новые вопросы