Информатика, вопрос задал 1223445565 , 1 год назад

100 баллов
Язык C++
Написать программу
Задано натуральное число N. Найти количество натуральных чисел, не превосходящих N и не делящихся ни на одно из чисел 2,3,5.

Ответы на вопрос

Ответил Koljisto
1

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int N;

cout << "Введите N: ";

cin >> N;

int counter = 0;

for (int i = 1; i < N; i++) {

 if (!(i % 2 == 0) && !(i % 3 == 0) && !(i % 5 == 0)) {

  counter++;

  cout << i << endl;

 }

}

cout << "Итого: " << counter << endl;

}


1223445565: Спасибо большое!
1223445565: А тут не поможешь? https://znanija.com/task/33573027
Новые вопросы