Информатика, вопрос задал sarkisantigran9 , 6 лет назад

100 БАЛЛОВ PYTHON ПОМОГИТЕ
Даны два списка целых чисел, оба списка заполняются с клавиатуры. В первый список вводится три числа, во второй — семь чисел. Напишите программу, которая запрашивает у пользователя эти числа, затем расширяет первый список элементами второго и после этого оставляет в первом списке только уникальные элементы, то есть удаляет лишние повторы чисел. Условный оператор использовать нельзя.

Пример:

Введите 1-е число для первого списка: 1

Введите 2-е число для первого списка: 2

Введите 3-е число для первого списка: 3

Введите 1-е число для второго списка: 2

Введите 2-е число для второго списка: 4

Введите 3-е число для второго списка: 6

Введите 4-е число для второго списка: 3

Введите 5-е число для второго списка: 3

Введите 6-е число для второго списка: 2

Введите 7-е число для второго списка: 1



Первый список: [1, 2, 3]

Второй список: [2, 4, 6, 3, 3, 2, 1]



Новый первый список с уникальными элементами: [4, 6, 3, 2, 1]

Ответы на вопрос

Ответил SheWhoRunsOnTheWaves
1

Ответ:

a = [0] * 3

b = [0] * 7

for i in range(3):

   a[i] = int(input('Введите ' + str(i + 1) + '-е число для первого списка: '))

for i in range(7):

   b[i] = int(input('Введите ' + str(i + 1) + '-е число для второго списка: '))

print('Первый список:', a)

print('Второй список:', b)

a = a + b

a = list(set(a))

print('Новый первый список с уникальными элементами:', a)

Объяснение:

1) Сначала создаем два списка (а и b) и сразу задаем им нужное количество элементов:

  • a = [0] * 3
  • b = [0] * 7

2) Потом считываем эти элементы с клавиатуры и одновременно выводим сообщение "Введите i-е число для первого/второго списка: "

  • for i in range(3):
  •    a[i] = int(input('Введите ' + str(i + 1) + '-е число для первого списка: '))
  • for i in range(7):
  •    b[i] = int(input('Введите ' + str(i + 1) + '-е число для второго списка: '))

3) Потом выводим первый и второй список:

  • print('Первый список:', a)
  • print('Второй список:', b)

4) Добавляем в первый список элементы второго:

  • a = a + b

5) Оставляем только уникальные элементы: превращаем список а в множество (set) - контейнер для хранения только уникальных элементов. Так как нам надо вывести его в виде списка, опять приводим к типу list:

  • a = list(set(a))

6) Выводим получившийся список с уникальными элементами:

  • print('Новый первый список с уникальными элементами:', a)

#SPJ1

Новые вопросы