10) Ниже записана программа. Получив на вход число , эта программа печатает два числа, и . Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 10.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:=L+1;
if M < x then begin
M:= (x mod 10) * 2;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.
И объясните пожалуйста
Ответы на вопрос
Ответил MaxKrivich
0
вот вставь проверь там напишет при каких значениях
var x, L, M,i,i1: integer;
begin
for i:=0 to 1000 do
begin
i1:=i;
L:=0;
M:=0;
while i1 > 0 do
begin
L:=L+1;
if M < i1 then
begin
M:= (i1 mod 10) * 2;
end;
i1:= i1 div 10;
end;
writeln(L);
write(M);
end;
readln;
end.
var x, L, M,i,i1: integer;
begin
for i:=0 to 1000 do
begin
i1:=i;
L:=0;
M:=0;
while i1 > 0 do
begin
L:=L+1;
if M < i1 then
begin
M:= (i1 mod 10) * 2;
end;
i1:= i1 div 10;
end;
writeln(L);
write(M);
end;
readln;
end.
Новые вопросы