10 класс
Составьте программу, позволяющую ввести фамилию, имя и отчество учащегося, разделенные пробелом, и вывести фамилию и инициалы.
Пример ввода:
Иванов Сергей Михайлович { строка s }
Пример вывода:
Иванов С. М.
Паскаль
Ответы на вопрос
Ответил asdfasdfkjqwweerpdsa
0
var
str: string;
i,k: integer;
begin
write('Введите фамилию, имя и отчество: ');
readln(str);
for i:=1 to length(str) do
begin
if (str[i]<>' ')and(k=0) then
write(str[i]) else
if str[i]=' ' then
begin
inc(k);
write(' ',str[i+1],'.');
end;
end;
readln;
end.
попробуй эту программу.
Ответил ВиКтоРиЯ29584
0
Учительница сразу поймет , что списано
Ответил ВиКтоРиЯ29584
0
У нас можно использовать
Length
Copy
Delete
Insert
Pos
Length
Copy
Delete
Insert
Pos
Ответил Аноним
0
Ну так это в условии задания указывать, что такие ограничения.
Новые вопросы
Другие предметы,
2 года назад
Русский язык,
2 года назад
Алгебра,
7 лет назад
Физика,
7 лет назад
Физика,
9 лет назад