10 Класс
Напишите программу, которая сначала считывает натуральное число, а затем печатает значение наибольшей из цифр в его записи в системе счисления с основание 4. Исходное число не превышает 10000.
Заранее спасибо!
Ответы на вопрос
Ответил Михалыч1488
0
var i,k,m,a:integer;
begin
write('n: '); readln(a); m:=0;
for i:=0 to 6 do begin k:=(a shr (2*i))and 3; if k>m then m:=k end;
writeln('Max 4-ciffer is ', m); readln
end.
begin
write('n: '); readln(a); m:=0;
for i:=0 to 6 do begin k:=(a shr (2*i))and 3; if k>m then m:=k end;
writeln('Max 4-ciffer is ', m); readln
end.
Новые вопросы
Физика,
2 года назад
Математика,
2 года назад
Биология,
9 лет назад
Математика,
9 лет назад
Математика,
9 лет назад