Информатика, вопрос задал godvanvasiliy , 2 года назад

1. Заполнить массив из 50 элементов случайными числами в интервале [-100,100] 2. подсчитать отдельно число отрицательных элементов.
3. Определите количество нечётных отрицательных элементов массива

Ответы на вопрос

Ответил merkkaa
0

from random import randint

mas = [randint(-100, 100) for i in range(50)]

count = 0

countn = 0

for i in mas:

   if i < 0:

       count += 1

       if i % 2 != 0:

           countn += 1

print(count, countn)


nastkess: здравствуйте, У меня будет олимпиада 8 мая в 7:00 до 10:00,вы сможете мне помочь пожалуйста?
merkkaa: зачем вам нужна эта олимпиада, если вы хотите получить все ответы?
merkkaa: может и не все, но всё же?
merkkaa: к тому же, я как понимаю, олимпиада по плюсам, это уже совсем не моё.
nastkess: в отбор хочу попасть
nastkess: а вы можете еще кого-нибудь посоветовать?
merkkaa: Ну и зачем вам это? попадёте в отбор и вам опять ответы нужны будут. Откажитесь и все.
merkkaa: Зачем участвовать в том, чего плохо знаешь?
nastkess: я знаю нормально,но не уверен что смогу написать олимпиаду
nastkess: ладно,проехали
Новые вопросы