Информатика, вопрос задал patauvlad , 2 года назад

1 задание)Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно. Написать программу, позволяющую найти и вывести количество пар элементов массива, сумма которых нечётна и положительна. Под парой подразумевается два подряд идущих элемента массива. Язык Pascal
2 задание) Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 10 000 включительно. Написать программу, которая подсчитывает сумму первых цифр двузначных нечётных элементов, а затем заменяет каждый двузначный нечётный элемент на число, равное найденной сумме. Гарантируется, что в массиве есть хотя бы один двузначный нечётный элемент. В качестве результата необходимо вывести сначала вторую половину массива, а затем первую. Например, для массива из восьми элементов:
7 15 9 333 22 71 14 95
программа должна получить массив
7 17 9 333 22 17 14 17
и вывести числа:
22 17 14 17 7 17 9 333
язык Pascal

Ответы на вопрос

Ответил fedrfedr
1

Ответ:

program ArrayTest;

var

 a: array [1..20] of Integer;

 i, s, c: Integer;

begin

 Randomize;

 for i := Low (a) to High (a) do begin

   a [i] := Random (20001) - 10000;

   Write (a [i], ' ');

 end;

 c := 0;

 WriteLn;

 for i := Low (a) to High (a) - 1 do begin

   s := a [i] + a [i + 1];

   if (s mod 2 <> 0) and (s > 0) then begin

     Inc (c);

     WriteLn (a [i], ' ', a [i + 1]);

   end;

 end;

 WriteLn ('Количество пар элементов = ', c);

 ReadLn;

end.


patauvlad: можешь вторую решить,если не сложно ?
Новые вопросы