1.Составьте программу заполнения массива НЕ ИСПОЛЬЗУЯ КЛАВИАТУРУ числами -2, 4,-6,8,-10...20.
2.Сформировать одномерный массив из 30 элементов (задаются ГСЧ-рандомно) из интервала -3..3. Массив вывести.Найти номер положительных элементов и их сумму чисел.
Ответы на вопрос
Ответил HRAshton
0
Буду считать, что да, он самый востребованный тут =)
1)
var a: array [0..9] of integer;
i, o: integer;
begin
for i := 1 to 20 do
begin
if (i mod 4 = 0) then a[o] := i
else if (i mod 4 = 2) then a[o] := -1 * i;
if (i mod 4 mod 2 = 0) then o := o + 1;
end;
for i := 0 to 9 do
writeln(a[i]);
end.
2)
var a: array [0..30] of integer;
i, o: integer;
s: string;
begin
for i := 1 to 30 do
begin
a[i] := random(6) - 3;
end;
writeln('Массив:');
for i := 0 to 30 do
begin
writeln('[', i, '] => ', a[i]);
if (a[i] > 0) then
begin
o := o + a[i];
s := s + inttostr(i) + ' ';
end;
end;
writeln('Номера положительных чисел: ', s);
end.
1)
var a: array [0..9] of integer;
i, o: integer;
begin
for i := 1 to 20 do
begin
if (i mod 4 = 0) then a[o] := i
else if (i mod 4 = 2) then a[o] := -1 * i;
if (i mod 4 mod 2 = 0) then o := o + 1;
end;
for i := 0 to 9 do
writeln(a[i]);
end.
2)
var a: array [0..30] of integer;
i, o: integer;
s: string;
begin
for i := 1 to 30 do
begin
a[i] := random(6) - 3;
end;
writeln('Массив:');
for i := 0 to 30 do
begin
writeln('[', i, '] => ', a[i]);
if (a[i] > 0) then
begin
o := o + a[i];
s := s + inttostr(i) + ' ';
end;
end;
writeln('Номера положительных чисел: ', s);
end.
Новые вопросы
Математика,
6 лет назад
География,
6 лет назад
Математика,
10 лет назад
Информатика,
10 лет назад
География,
10 лет назад