1.Составьте программу вывода матрицы:
1 1 1 1
2 2 2 2
3 3 3 3
2.Составьте программу вывода матрицы:
1 2 3 4
1 2 3 4
1 2 3 4
Ответы на вопрос
Ответил Аноним
0
{Задача 1}
type Mat = arrsay [1..3, 1..4] of integer;
var i: integer;
A: Mas;
begin
for i:=1 to 3 do
begin
for j:=1 to 4 do
Write (i:4);
WriteLn;
end;
ReadLn;
end.
{Задача 2}
type Mat = arrsay [1..3, 1..4] of integer;
var i:integer;
A: Mas;
begin
for i:=1 to 3 do
begin
for j:=1 to 4 do
Write (j:4);
WriteLn;
end;
ReadLn;
end.
type Mat = arrsay [1..3, 1..4] of integer;
var i: integer;
A: Mas;
begin
for i:=1 to 3 do
begin
for j:=1 to 4 do
Write (i:4);
WriteLn;
end;
ReadLn;
end.
{Задача 2}
type Mat = arrsay [1..3, 1..4] of integer;
var i:integer;
A: Mas;
begin
for i:=1 to 3 do
begin
for j:=1 to 4 do
Write (j:4);
WriteLn;
end;
ReadLn;
end.
Ответил Аноним
0
Прошу прощения, тип Mat, и описывать массив А, которым не пользовались.
Ответил Аноним
0
Зато ты не молодец - налепил ошибок и не удосужился хотя бы раз свою программу выполнить. Readln в конце порадовал своей ненужностью. В общем, в свое время я за подобное решение ставил своим первокурсникам двойки...
Ответил Аноним
0
var
i,j:integer;
begin
for i:=1 to 3 do
begin for j:=1 to 4 do Write(i:2); Writeln end
end.
Результат выполнения программы:
1 1 1 1
2 2 2 2
3 3 3 3
var
i,j:integer;
begin
for i:=1 to 3 do
begin for j:=1 to 4 do Write(j:2); Writeln end
end.
Результат выполнения программы:
1 2 3 4
1 2 3 4
1 2 3 4
Программы отличаются ровно одним символом - именем переменной в обращении к процедуре вывода: Write(i:2); и Write(j:2);
i,j:integer;
begin
for i:=1 to 3 do
begin for j:=1 to 4 do Write(i:2); Writeln end
end.
Результат выполнения программы:
1 1 1 1
2 2 2 2
3 3 3 3
var
i,j:integer;
begin
for i:=1 to 3 do
begin for j:=1 to 4 do Write(j:2); Writeln end
end.
Результат выполнения программы:
1 2 3 4
1 2 3 4
1 2 3 4
Программы отличаются ровно одним символом - именем переменной в обращении к процедуре вывода: Write(i:2); и Write(j:2);
Новые вопросы
Математика,
2 года назад
Математика,
9 лет назад