Информатика, вопрос задал Taskmaster , 10 лет назад

     1)составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal

     2)составьте программу вычисления суммы элементов от первого отрицательного и до конца. Pascal

Ответы на вопрос

Ответил Olia1904
0

program massiv1;

uses CRT;

var i,N,P:integer;

a:array [1..N] of integer;

begin

P:=1;

read(N);

for i:=1 to N do

begin

read a[i];

end;

for i:=1 to N do

begin

if  a[i] >o 

then

P:=P*a[i];

end;

write(P);

readkey;

end.

Новые вопросы