1. Составьте программу, проверяющую, что введенное число является четным или нечетным
2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы на вопрос
Ответил Provider
12
//Задача 1
var d:integer;
begin
readln(d);
if d mod 2 =0 then
Writeln('Четное')
else
Writeln('Не четное');
end.
//Задача 2
var d:integer;
begin
readln(d);
if d mod 3 =0 then
Writeln('Делится') else
Writeln('Не делится');
end.
var d:integer;
begin
readln(d);
if d mod 2 =0 then
Writeln('Четное')
else
Writeln('Не четное');
end.
//Задача 2
var d:integer;
begin
readln(d);
if d mod 3 =0 then
Writeln('Делится') else
Writeln('Не делится');
end.
Ответил archery
0
1)
var
i: integer;
begin
readln(i);
Writeln('Четное? - ', i mod 2 = 0);
end.
2)
var
i: integer;
begin
read(i);
Writeln('Делится на 3? - ', i mod 3 = 0)
end.
var
i: integer;
begin
readln(i);
Writeln('Четное? - ', i mod 2 = 0);
end.
2)
var
i: integer;
begin
read(i);
Writeln('Делится на 3? - ', i mod 3 = 0)
end.
archery:
"правильный" вариант уже написан. Я написала другой вариант. Может автору так больше понравится
Новые вопросы