Информатика, вопрос задал loix222 , 7 лет назад

1. Составьте программу, которая:
a) определяет коды двух введенных с клавиатуры символов.
б) выполняет операцию сцепление трех введенных с клавиатуры символов.
в) выполняет сравнение двух введенных с клавиатуры символов и выводят результат сравнение на экран. Например: 'a'<'б' , 'д'='д' , 'я'<'Ы'
г)выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке возрастания их кодов.

Ответы на вопрос

Ответил angilinapavlowa
0

а), б)


var a, b, c: char;


begin


 writeln('Введите 3 символа');


 readln(a, b, c);


 writeln('Результат сцепления: ', a+b+c);


 if a>b then writeln(a,'>', b);


 if a>c then writeln(a,'>', c);


 if a=b then writeln(a, '=', b);


 if a=c then writeln(a, '=', c);


 if a<b then writeln(a, '<', b);


 if a<c then writeln(a, '<', c);


 if b>c then writeln(b, '>', c);


 if b<c then writeln(b, '<', c);


end.


в)


var a, b: char;


begin


 writeln('Введите 2 символа');


 readln(a, b);


 if a>b then writeln(b,'  ', a);


 if a<b then writeln(a,'  ', b);


 if a=b then writeln(a,'  ', b);


end.

если правильно дай пожалуйста лутший ответ

Ответил loix222
0
а г?
Ответил angilinapavlowa
0
ну у меня получилось только до в
Ответил angilinapavlowa
0
пожалуйста извини
Ответил loix222
0
a)b)а что надо место
Введите 3 символа
Результат сцепления
Ответил loix222
0
и в)
Введите 2 символа
Новые вопросы