1)Составьте и. напишите программу для вычисления 10x+12x²+204
2)Напишите логическое выражение на языке Паскаль для решения следующей задачи:
Условие верно (Вывести на экран "верно") если с меньше 55 и больше 4
3) Запишите условие на языке Паскаль для выражения:
Увеличить число b на 5, если b кратно 2 и уменьшить на 4 в противном случае.
4)исправить ошибки в следующем фрагменте программы:
var l, k:real; s: real;
begin
k=81
s:=4
for i=1 to k
s=s/2
end
5)


Ответы на вопрос
Ответ:
1) # Считываем значение переменной x с клавиатуры
x = float(input("Введите значение переменной x: "))
# Вычисляем значение выражения
result = 10 * x + 12 * (x ** 2) + 204
# Выводим результат на экран
print("Значение выражения при x =", x, "равно", result)
2) if (a > 4) and (a < 55) then
writeln('верно');
3) Условие на языке Паскаль для данного выражения:
if (b mod 2 = 0) then
b := b + 5
else
b := b - 4;
Данное условие использует оператор if для проверки кратности числа b двум (через оператор деления с остатком mod). Если b кратно 2, то к нему будет прибавлено 5, иначе к нему будет вычтено 4. Обратите внимание, что блок else будет выполнен только в том случае, если первое логическое условие не будет истинным.
4) var
l, k, s: real;
begin
k := 81; // знак присваивания должен быть :=
s := 4;
for i := 1 to k do
s := s / 2; // добавляем оператор цикла и правильный знак деления
end.
5) print(" _____ ")
print(" ___/ \\___")
print(" / \ / \ ")
print("| | | |")
print("| |___| |")
print("|___ ___ ___|")
print(" | | | | ")
print(" |_|___|_| ")