1.Составить программу с данным выражением.
y = {frac{1}{sin},x < -2
(x-4)³, x ≥ -2
2.Составить программу,которая по номеру класса определяет,в начальной,основной или старшей школе обучается ученик.
Ответы на вопрос
Ответил petyaGavrikov
0
1.
var x,y:real;
begin
write('x = ');
readln(x);
if x<-2 then y:=1/sin(x) else y:=(x-4)*(x-4)*(x-4);
writeln('y = ',y);
end.
Пример:
x = 2
y = -8
2.
var n:integer;
begin
write('n = ');
readln(n);
case n of
1..4 : writeln('Начальная школа');
5..9 : writeln('Основная школа');
10..11: writeln('Старшая школа');
else writeln('Ошибка ввода');
end;
end.
Пример:
n = 7
Основная школа
var x,y:real;
begin
write('x = ');
readln(x);
if x<-2 then y:=1/sin(x) else y:=(x-4)*(x-4)*(x-4);
writeln('y = ',y);
end.
Пример:
x = 2
y = -8
2.
var n:integer;
begin
write('n = ');
readln(n);
case n of
1..4 : writeln('Начальная школа');
5..9 : writeln('Основная школа');
10..11: writeln('Старшая школа');
else writeln('Ошибка ввода');
end;
end.
Пример:
n = 7
Основная школа
Ответил ArinaKibizova
0
Еще раз Вам спасибо!Я даже не знаю как Вас отблагодарить!Вы невероятный человек!!!
Ответил petyaGavrikov
0
Пожалуйста )
Новые вопросы
История,
2 года назад
Математика,
2 года назад
Геометрия,
8 лет назад
Математика,
8 лет назад
Обществознание,
9 лет назад