1)Составить программу нахождения наибольшего общего делителя НОД. Составить блок-схему
2)Составить программу решения примера
1+2+4+6+8..
Ответы на вопрос
Ответил blowberryninja
0
program pr1;
var x,y, nod:integer;
begin
readln(x,y);
repeat
if x > y then x:=x mod y
else y:=y mod x
until x*y=0;
nod:=x+y;
writeln('НОД=', nod);
end.
program pr2;
var i,n,sum:integer;
begin
readln(n);
sum:=1;
for i:=1 to n do
if i mod 2 = 0 then inc(sum,i);
writeln(sum);
end.
var x,y, nod:integer;
begin
readln(x,y);
repeat
if x > y then x:=x mod y
else y:=y mod x
until x*y=0;
nod:=x+y;
writeln('НОД=', nod);
end.
program pr2;
var i,n,sum:integer;
begin
readln(n);
sum:=1;
for i:=1 to n do
if i mod 2 = 0 then inc(sum,i);
writeln(sum);
end.
Новые вопросы