1.Составить программу, которая формирует массив из 20 целых случайных чисел, принадлежащих промежутку [0,30]. Найти в этом массиве сумму элементов, меньше 10.
2. Составить программу, которая формирует массив из 15 целых случайных чисел, принадлежащих промежутку [-10,10]. Посчитать в этом массиве количество положительных и отрицательных элементов.
3. Составить программу, которая формирует массив из 20 целых случайных чисел, принадлежащих промежутку [0,100]. Найти в этом массиве разность максимального значения среди первых 10 элементов и минимального значения среди 10 последних элементов этого массива.
Ребята, пожалуйста, кто шарит в информатике, помогите. Очень сильно прошу
Ответы на вопрос
1.Составить программу, которая формирует массив из 20 целых случайных чисел, принадлежащих промежутку [0,30]. Найти в этом массиве сумму элементов, меньше 10.
program A;
var
numbers: array[1..20] of integer;
i, sum: integer;
begin
for i := 1 to 20 do
begin
numbers[i] := random(31);
if numbers[i] < 10 then sum += numbers[i];
end;
writeln(sum);
end.
2. Составить программу, которая формирует массив из 15 целых случайных чисел, принадлежащих промежутку [-10,10]. Посчитать в этом массиве количество положительных и отрицательных элементов.
program B;
var
numbers: array[1..15] of integer;
i, positive_count, negative_count: integer;
begin
for i := 1 to 15 do
begin
numbers[i] := random(-21) + 10;
if numbers[i] > 0 then positive_count += 1;
if numbers[i] < 0 then negative_count += 1;
end;
writeln(positive_count);
writeln(negative_count);
end.
3. Составить программу, которая формирует массив из 20 целых случайных чисел, принадлежащих промежутку [0,100]. Найти в этом массиве разность максимального значения среди первых 10 элементов и минимального значения среди 10 последних элементов этого массива.
program C;
var
numbers: array[1..20] of integer;
i: integer;
max: integer = 0;
min: integer = 200;
begin
for i := 1 to 20 do
begin
numbers[i] := random(101);
if (i <= 10) and (numbers[i] > max) then
max := numbers[i];
if (i > 10) and (numbers[i] < min) then
min := numbers[i];
end;
writeln(max - min);
end.
Ответ:
Язык: Python
Объяснение:
1.
import random
a = [random.randint(0, 30) for i in range(20)]
sum = 0
for i in a:
if i > 10:
sum+=a
2.
a = [random.randint(-10, 10) for i in range(15)]
pol = 0
otr = 0
for i in a:
if a > 0:
pol+=1
elif a < 0:
otr+=1
3.
a = [random.randint(0, 100) for i in range(20)]
raznost = max(a[:10]) - min(a[:-10:-1])