Информатика, вопрос задал Icarus1 , 2 года назад

1. Составить блок схему алгоритма и написать программу на языке программирования С++, вычисления корней квадратного уравнения, с проверкой вводимого значения а на ноль. Рассмотреть все возможные варианты решения.

2. Сделать описание программы.

3. Отчет оформить в документе WORD.

Квадратное уравнение — это уравнение вида ax2 + bx + c = 0, где коэффициенты a, b и c — произвольные числа, причем a ≠ 0.

все квадратные уравнения можно условно разделить на три класса:

1. Не имеют корней;

2. Имеют ровно один корень;

3. Имеют два различных корня.

Для определения количества корней квадратно уравнения нужно вычислить— дискриминант -D = b2 − 4ac.

Пусть дано квадратное уравнение ax2 + bx + c = 0. Тогда дискриминант — это просто число D = b2 − 4ac.

1. Если D 0, корней будет два.
2. Если D = 0, есть ровно один корень;
3. Если D > 0, корней будет два.


shibgena: Могу просто программу написать
Icarus1: В каком смысле?
shibgena: в смысле без описания и отчета в word
Icarus1: Просто текст этого задания скинь, ок? Я имею ввиду скопируй потом всё из С++ и мне скинь, ок?
Icarus1: 1. Составить блок схему алгоритма и написать программу вычисления факториала, используя цикл do..while, с проверкой вводимого значения на ноль и на отрицательное значение.
2. Сделать описание программы.
Факториа́л — функция, определённая на множестве неотрицательных целых чисел. обозначается n!
Факториал натурального числа n определяется как произведение всех натуральных чисел от 1 до n включительно:
n!=1*2*3*4* ….*n
Icarus1: Такое сможешь ещё сделать?
Icarus1: Если да, то создам потом задание
Icarus1: сделаешь?

Ответы на вопрос

Ответил shibgena
1

Ответ:

Объяснение:

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

   int a, b, c, d;

   cout <<"vvedite a, b , c" << endl;

   cin >> a >> b >>c;

   if(a == 0.0)

   {

       cout << "a ravo 0!" << endl;

       return 0;

   }

   d = b*b - 4 * a * c;

   if(d < 0)

   {

       cout << "net kornei" << endl;

       return 0;

   }

   if(d == 0)

   {

       cout << "odin koren, x = " <<(-b)/2*a <<endl;

       return 0;

   }

   cout << "dva korna, x1 = " <<(-b + sqrt(d))/2*a << " x2 = " <<(-b - sqrt(d))/2*a << endl;

   return 0;

}

Приложения:

Icarus1: а второе сможешь? если что новое вопрос создам
shibgena: сек
Icarus1: А ты сделал для 3х пунктов?
1. Если D 0, корней будет два.
2. Если D = 0, есть ровно один корень;
3. Если D > 0, корней будет два.
shibgena: В программе все проверяется, смотри скрин внимательно
shibgena: если D<0, значит корей нет
Icarus1: А 2 сможешь? мне создавать вопрос?
shibgena: давай
Icarus1: там обязательно нужно do..while
shibgena: Я сделал с do while
shibgena: Факториал
Новые вопросы