1. Составить блок схему алгоритма и написать программу вычисления факториала, используя цикл do..while, с проверкой вводимого значения на ноль и на отрицательное значение.
2. Сделать описание программы.
3. Отчет оформить в документе WORD.
Факториа́л — функция, определённая на множестве неотрицательных целых чисел. Название происходит от лат. factorialis — действующий, производящий, умножающий; обозначается n!
Факториал натурального числа n определяется как произведение всех натуральных чисел от 1 до n включительно:
n!=1*2*3*4* ….*n
Ответы на вопрос
Ответил shibgena
2
Ответ:
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
int x, faktorial;
faktorial = 1;
cout << "vvedite x" << endl;
cin >> x;
if(x <= 0)
{
cout << "x dolgen bit' > 0" << endl;
return 0;
}
cout << "faktorial " << x " = "; //выводим заготовку для результата, так как x будет меняться
do
{
faktorial *= x; //faktorial = faktorial * x;
}
//если в условие цикла подставить число, то 0 преобразуется к "ложь", а ненулевое значение к "истина"
while(--x);//уменьшаем x на 1, затем проверяем его на 0
cout << faktorial << endl;
return 0;
}
Объяснение:
Приложения:

Icarus1:
Слушай, а с тобой списаться можно где то? в вк например, просто есть небольшие вопросы с оформлением
Новые вопросы