Информатика, вопрос задал adhduudsjjdjdj , 2 года назад

1. Составить алгоритм и программу для вычисления значения функции по заданному значению аргумента.
2. Составить алгоритм вычисления функции по заданным параметрам и значению аргумента
(ПАСКАЛЬ) ​

Приложения:

Ответы на вопрос

Ответил fedrfedr
2

Ответ:

program Calc1;

var

 m, k, x, y: Double;

begin

 Write ('Введите m, k, x: ');

 ReadLn (m, k, x);

 if m * k - x >= 2 then

   y := Sqr (x) + Sin (6 * x) - (k + 1)

 else

   y := Power (x, 3) - m * k + 3;

 WriteLn ('y = ', y :20 :10);

 ReadLn;

end.

program Calc2;

const

 E = 1;

 F = -2;

var

 x, y: Double;

begin

 Write ('Введите x: ');

 ReadLn (x);

 if x > Pi then

   y := Sqr (Pi) + E * x * Ln (x)

 else if x < 0 then

   y := 0

 else

   y := Pi / 4 - F * x;

 WriteLn ('y = ', y :20 :10);

 ReadLn;

end.

Новые вопросы