Информатика, вопрос задал DIMASIQUE , 2 года назад

1) Постройте и запишите в виде программы алгоритм вычисления суммы квадратов 10 произвольных чисел, вводимых с клавиатуры

2) Выведите на экран все четные числа, которые находятся между числами M и N. Числа M и N задайте сами

3) Составьте программу нахождения суммы четных чисел, находящихся в промежутке от 26 до 88

В ПАЙТОНЕ ПЛИЗ!!!!!!!!! 35 БАЛЛОВ!!


artemius75: Могу на Pascale, а ты уже напишешь на Python
DIMASIQUE: Давай
artemius75: Если что-то не понял пиши в комментах

Ответы на вопрос

Ответил artemius75
0

Ответ:

1) С помощью масива можно уменьшить кол-во переменных

var a,b,c,d,f,g,h,j,k,l,o :int64;

begin

readln(a,b,c,d,f,g,h,j,k,l);

o:= sqr(a) + sqr(b) + sqr(c) + sqr(d) + sqr(f) + sqr(h) + sqr(j) + sqr(k) + sqr(l) + sqr(g);

writeln(o);

end.

2) Можно было решить с помощью цыкла for, ток я хз как он тут обозначается. Чтобы не делать лишнее действие " a := a + 1; "

var a,b,c,d :int64;

begin

writeln('Введите числа:');

readln(a,b);

while a < b do begin

   c:= a mod 2;

   if c = 0 then writeln(a);

   a := a + 1;

 end;

end.

3)

var a,b,c,d :int64;

begin

a:= 27;

while a < 87 do begin

   a := a+1;

   c:= a mod 2;

   if c = 0 then begin    

     d:=a + d;

     writeln(a);

   end;

 end;

 writeln(d);

end.

Объяснение:


DIMASIQUE: Спасибо, на пайтон так же переписать просто?
artemius75: Пожалуйста, нет))Загугли как в пайтоне пишутся цыклы while
Новые вопросы