1.Определите значение, которое выведет программа:
S:=1;
For z:=1 to 8 do a[z]:=sqr(z);
for k:=1 to 8 do
if a[k]>9 then a[k]:=2;
for z:=4 to 8 do S:=S*A[k];
write(S);
2.Что вычисляет данный алгоритм?
var z:integer;A:array[1..8] of integer;
begin
S:=0;
For z:=1 to 8 do S:=sqr(z);
end.
Выберите один ответ:
a. формирует массив А, каждый элемент которого равен квадрату z
b. формирует массив А, каждый элемент которого равен квадрату своего индекса
c. Находит квадрат последнего значения переменной цикла
d. Находит корни квадратные из переменной цикла и сохраняет в массив
e. Находит сумму квадратов индексов
f. формирует массив А, каждый элемент которого равен 4
3. Назовите конструкцию:
d:=15; a:=0; z:=2;
while a
begin
a:=a+z; write(a)
end;
Выберите один ответ:
a. Полное ветвление
b. Выбор
c. Неполное ветвление
d. Составной оператор
e. Цикл "Повтори N раз"
f. Цикл "Пока" с предусловием
g. Цикл "Пока" с постусловием
h. Следование
i. Неполное ветвление
Ответы на вопрос
Ответил deline1
0
Ответ:
1)S=1*2*2*2*2*2=32
2)c
3)f
Новые вопросы
Английский язык,
1 год назад
Физика,
1 год назад