1. Определите, что делает следующая программа и какой результат она выдаст на заданном массиве (1,4,0,-1,6).
Var a:array[1..5] of integer; i, b:integer;
begin
b:=a[ 1 ];
for i:=2 to n do if a[i]>b then b:=a[i];
writeln(b)
end.
2. Чему будет равно значение k после выполнения программы?
Var
m, k:integer;
begin
m:=0; k:=1;
while (m<5) do m:=m+1; k:=k+m;
writeln(k);
end.
Варианты ответов: а) 2;
б) 3;
в) 4;
г) 5.
Заранее спасибо!
Ответы на вопрос
Ответил efimmoiseevp0qzjx
0
1. Результат программы - 4
2. После выполнения программы k будет равен 5
2. После выполнения программы k будет равен 5
Ответил coolscrewp0qynf
0
большое спасибо!
Новые вопросы