Информатика, вопрос задал Мальвинкамандаринка , 9 лет назад

1) Одномерный массив из 6 элементов заполнить случайным образом числами от 5 до 17. Поменять местами 5-ый и 7-ой элементы массива, а 4-ый элемент увеличить в 3 раза. Вывести на экран монитора первоначальный и преобразованный массивы в строчку.

Пожалуйста, помогите составить программу массива.

Ответы на вопрос

Ответил Dmon55
0
В задании ошибка: Одномерный массив из 6 элементовПоменять местами 5-ый и 7-ой элементы 

__________________________

#include <iostream>
#include <stdlib.h>      
#include <time.h>    

void Swap(int & a, int & b) {int t = a; a = b; b = t;}

int main(){
    srand(time(NULL));

    const int n = 6;
    int f[n], s[n];

    for (unsigned int i = 0; i < n; ++i) {
        f[i] = rand() % 12 + 5;
        s[i] = f[i];
    }

    // Меняем 5 и 6 элементы местами
    Swap(s[4], s[5]);
    s[3] *= 3;

    std::cout << "First: ";
    for (unsigned int i = 0; i < n; ++i) {
        std::cout << f[i] << ", ";
    }
    std::cout << std::endl;

    std::cout << "Second: ";
    for (unsigned int i = 0; i < n; ++i) {
        std::cout << s[i] << ", ";
    }
    std::cout << std::endl;
    return 0;
}
  
Ответил Мальвинкамандаринка
0
А на Паскале можешь написать?
Новые вопросы