Информатика, вопрос задал Hilis , 7 лет назад

1.напишите программу вычисления значений переменной а.если a=2x+18y

2.Напишите программу вычисления длины гипотенузы прямоугольного треугольника​

Ответы на вопрос

Ответил G4rp1x
0

Ответ :

С++ :

1)

#include <iostream>

using namespace std;

int x,y,a;

int main()

{

cout << "Enter X and Y " << endl;

cin >> x >> y;

a=2*x + 18*y;

cout << "a = " << a;

}

2)

#include <iostream>

#include <cmath>

using namespace std;

float a,b,c;

int main()

{

cout << "Enter A and B " << endl;

cin >> a >> b;

c=sqrt(pow(a , 2) + pow(b , 2));

cout << "c = " << c;

}

Комментарий :

  • a,b - катеты, c - гипотенуза.
  • pow(a,b) - возведение числа a в степень b ( аналогом может служить умножения переменной самой на себя)

2)

Pascal :

program ideone;

uses crt;

var a,b,c:real;

begin

 clrscr;

 write('Введите А и В');

 readln(a,b);

 c:=sqrt(a*a + b*b);

 writeln(c);

end.

1)

program ideone;

uses crt;

var a,x,y:integer;

begin

 clrscr;

 write('Введите X и Y ');

 readln(x,y);

 a:=2*x + 18*y;

 writeln(a);

end.

Ответил Hilis
0
через Паскаль можно 2 задачу ?
Ответил G4rp1x
0
могу объяснить примерный алгоритм или минут за 5 понять как писать подобное на паскале. Что выберет ?
Ответил G4rp1x
0
Выберете ?*
Ответил Hilis
0
надо на паскале , а не на сс+
Ответил G4rp1x
0
Я понимаю, хорошо , подождите немного
Новые вопросы