1) Напишите программу, которая запрашивает три цифры (от 0 до 9) и выводит
число, получающееся из этих цифр в том же порядке, что и при вводе.
Пример:
Ввод Вывод
1 2 3 123
0 1 2 12
2) Пользователь вводит с клавиатуры число больше нуля, необходимо вывести
все его цифры, начиная с конца.
Пример:
Ввод Вывод
12345 54321
3) В первый день улитка проползла 15 см. Каждый следующий день она
проползала на 2 см дальше. Определить какое общее расстояние проползет
улитка через N дней.
4) Пользователь вводит с клавиатуры целое шестизначное число. Написать
программу, которая определяет, является ли введенное число — счастливым
(Счастливым считается шестизначное число, у которого сумма первых
3 цифр равна сумме вторых трех цифр).
5) На чемодане стоит трехзначный код. Он состоит из цифр, которые не
повторяются. Напишите программу, которая выведет все возможные такие
комбинации цифр. А также определите сколько времени понадобится для
открытия чемодана в худшем случае, если на один такой набор уходит 3
секунды.
по с++
Ответы на вопрос
Программа, которая запрашивает три цифры (от 0 до 9) и выводит число, получающееся из этих цифр в том же порядке, что и при вводе:
#include <iostream>
int main() {
int a, b, c;
std::cin >> a >> b >> c;
std::cout << a << b << c << std::endl;
return 0;
}
Программа, которая выводит все цифры числа, введенного с клавиатуры, начиная с конца:
#include <iostream>
int main() {
int n;
std::cin >> n;
while (n > 0) {
std::cout << n % 10;
n /= 10;
}
std::cout << std::endl;
return 0;
}
Программа, которая определяет общее расстояние, которое проползет улитка через N дней:
#include <iostream>
int main() {
int n;
std::cin >> n;
int distance = 15; // расстояние в первый день
for (int i = 2; i <= n; i++) {
distance += 2; // каждый следующий день увеличивает расстояние на 2 см
}
std::cout << distance << std::endl;
return 0;
}
Программа, которая определяет, является ли введенное число счастливым:
#include <iostream>
int main() {
int n;
std::cin >> n;
int sum1 = (n / 100000) + ((n / 10000) % 10) + ((n / 1000) % 10); // сумма первых трех цифр
int sum2 = ((n / 100) % 10) + ((n / 10) % 10) + (n % 10); // сумма последних трех цифр
if (sum1 == sum2) {
std::cout << "Счастливое число" << std::endl;
} else {
std::cout << "Не счастливое число" << std::endl;
}
return 0;
}
Программа, которая выведет все возможные комбинации цифр трехзначного числа, а также определит, сколько времени понадобится для открытия чемодана в худшем случае:
#include <iostream>
#include <chrono>
int main() {
auto start = std::chrono::high_resolution_clock::now();
int count = 0;
for (int i = 1; i <= 9; i++) {
for (int j = 0; j <= 9; j++) {
if (j == i) continue;
for (int k = 0; k <= 9; k++) {
if (k == i || k == j) continue;
std::cout << i << j << k << std::endl;
count++;
}