Информатика, вопрос задал s4ndstrm , 2 года назад

1)Напишите программу которая запрашивает с консоли два целых числа (int n и int m) и выводит на экран все НЕЧЕТНЫЕ числа от n до m.
2)Напишите программу которая запрашивает с консоли два целых числа (int n и int m) и выводит на экран все числа от n до m которые делятся на 3 без остатка.
​с++


s4ndstrm: нужно с++
gamemasterpro958: привет помоги мне пожалуста сижу питаюсь решить но не могу задание в профиле

Ответы на вопрос

Ответил torvel
1

#include "iostream"

using namespace std;

int main() {

int n, m;

cout << "Task 1" << endl;

cout << "n = ";

cin >> n;

cout << "m = ";

cin >> m;

cout << "---------------------------" << endl;

if (m%2 != 0) {cout << "m = " << m << ", ";}

if (n % 2 != 0) { cout << "n = " << n << endl; }

else if (n % 2 != 0 and m % 2 != 0) {cout << "n = " << n << endl;cout << "m = " << m << endl;}

else if (n % 2 == 0 and m % 2 == 0) {cout << "Nothing" << endl;}

cout << "Task 2" << endl;

cout << "n = ";

cin >> n;

cout << "m = ";

cin >> m;

cout << "---------------------------" << endl;

if (m % 3 == 0) { cout << "m = " << m << ", "; }

if (n % 3 == 0) { cout << "n = " << n << endl; }

else if (n % 3 == 0 and m % 3 == 0) { cout << "n = " << n << endl; cout << "m = " << m << endl; }

else if (n % 3 != 0 and m % 3 != 0) { cout << "Nothing" << endl; }

system("pause");

return 0;

}


s4ndstrm: cout<<"_______"<
s4ndstrm: cout<<"_"<
s4ndstrm: <<"______"<< ендл .Внутри нужно что-то написать?
torvel: да)
torvel: ендл это перенос строки
torvel: час)
torvel: спс*)
s4ndstrm: Not at all
Новые вопросы