1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числами
в диапазоне (0,10), выводит его на экран, а затем выводит на экран квадраты всех элементов
массива.
Пример:
Массив: 5 6 2 3 1 4 8 7
Квадраты: 25 36 491 16 64 49
.
Ответы на вопрос
Ответил 65biso2
0
C# 8.0:
using System;
...
var Arr = RandomIntArr(0,10,8);
foreach(int i in Arr) Console.Write(i+" ");
Console.WriteLine();
foreach(int i in Arr) Console.Write(i*i + " ");
...
static int[] RandomIntArr(int Min, int Max, int ArrLen) {
Random rnd = new Random();
int[] Out = new int[ArrLen];
for (int i = 0; i < ArrLen; i++) Out[i] = rnd.Next(Min, Max+1);
return Out;
}
Ответил dana2625425
0
а можно в Паскаль?
Ответил 65biso2
0
А можно сразу указывать язык?
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Физика,
7 лет назад
Математика,
9 лет назад
Математика,
9 лет назад