Информатика, вопрос задал alexromanoff2007 , 6 лет назад

1.Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке [–5; 5] и находит сумму положительных элементов.
2.Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке [–2; 2] и находит произведение ненулевых элементов.
РЕШИТЬ НАДО НА ПИТОНЕ.

Ответы на вопрос

Ответил daniyarkanu
3

Решение:

Python

1.

import random

spisok = []

for i in range(10):

   rand = random.randint(-5, 5)

   spisok.append(rand)

print(spisok)

polozhitelnie = 0

for i in spisok:

   if i >= 0:

       polozhitelnie += i

print(polozhitelnie)

2.

spisok = []

for i in range(10):

   rand = random.randint(-2, 2)

   spisok.append(rand)

print(spisok)

ne_nulevie = 0

for i in spisok:

   if i > 0:

       ne_nulevie *= i

print(ne_nulevie)

Новые вопросы