Информатика, вопрос задал yunaleed , 1 год назад

1. Напишите программу, которая вычисляет среднее арифметическое отрицательных элементов одномерного массива D. [36] Массив состоит из 20 элементов, заполнен случайными числами в диапазоне [-10,10]​

Ответы на вопрос

Ответил chelodojmolovek12
0

Ответ:

Для решения данной задачи необходимо создать массив D из 20 случайных чисел в диапазоне [-10, 10], затем найти отрицательные элементы массива и вычислить их среднее арифметическое.

Вот код программы на языке Python:

import random

# Создание массива D из 20 случайных чисел

D = [random.randint(-10, 10) for i in range(20)]

# Нахождение отрицательных элементов и вычисление их среднего арифметического

neg_sum = 0

neg_count = 0

for x in D:

   if x < 0:

       neg_sum += x

       neg_count += 1

if neg_count > 0:

   neg_avg = neg_sum / neg_count

   print("Среднее арифметическое отрицательных элементов массива D: ", neg_avg)

else:

   print("Отрицательных элементов в массиве D нет.")

Объяснение:

Как работает программа:

С помощью модуля random создается массив D из 20 случайных чисел в диапазоне [-10, 10].

Создаются переменные neg_sum и neg_count, которые будут хранить сумму отрицательных элементов массива и их количество соответственно.

Цикл for проходит по каждому элементу массива D и проверяет, является ли он отрицательным. Если да, то к сумме neg_sum добавляется значение элемента, а к счетчику neg_count прибавляется 1.

Если количество отрицательных элементов neg_count больше 0, то вычисляется среднее арифметическое neg_avg путем деления суммы neg_sum на количество отрицательных элементов neg_count. Результат выводится на экран.

Если отрицательных элементов в массиве D нет, то выводится соответствующее сообщение.

Новые вопросы