Информатика, вопрос задал КаринаКит , 10 лет назад

1. Напишите программу, которая вводит значение 3-х переменных и выводит их произведение.
2. Напишите программу, определяющую, делится ли число без остатка на 7.
3. Напишите программу, которая вычисляет сумму чисел от 1 до N. Значение N вводится с клавиатуры (N<100).
Пожалуйста помогите, очень нужно.

Ответы на вопрос

Ответил Sky09
0
1.
uses crt;
var x,y,z:integer;
begin
     write('x:'); readln(x);
     write('y:'); readln(y);
     write('z:'); readln(z);
     write('x*y*z=',x*y*z);
end.

2.
uses crt;
var x:integer;
begin
     write('Введите число:'); readln(x);
     if x mod 7=0 then writeln('YES')
        else writeln('NO');
end.

3.
uses crt;
var n,x,sum:integer;
begin
     write('N:'); readln(n);
     sum:=0;
     for x:=1 to N do
         sum:=sum+x;
     write(sum);
end.
Новые вопросы