1)Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Входные данные
Входная строка содержит два целых числа.
Выходные данные
Программа должна вывести произведение введённых чисел.
Примеры
входные данные
6 12
выходные данные
72
входные данные
-7 15
выходные данные
-105
2)Напишите программу, которая вводит натуральное число N и находит сумму всех натуральных чисел от 1 до N .
Входные данные
Входная строка содержит единственное целое число N .
Выходные данные
Программа должна вывести сумму натуральных чисел от 1 до введённого числа N .
Примеры
входные данные
100
выходные данные
5050
3)Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b .
Входные данные
Входная строк содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b .
Выходные данные
Программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] .
Примеры
входные данные
2 5
выходные данные
54
4)Напишите программу, которая вводит натуральные числа a , b и N , и выводит на экран N псевдослучайных целых чисел на отрезке [ a , b ] .
Входные данные
Входная строка содержит три числа, разделённые пробелами: границы отрезка a и b и требуемое количество чисел N . Гарантируется, что a ≤ b .
Выходные данные
Программа должна вывести N случайных целых чисел в одной строке, разделив их пробелами.
Примеры
входные данные
10 20 5
выходные данные
10 10 19 12 13
ЗА ВСЁ РЕШЕНИЕ 99 БАЛЛОВ!!!!!!!
ПОМОГИТЕ РЕШИТЬ ПОЖАЛУЙСТА!!!!
Ответы на вопрос
Ответил ruslol
0
1)
var a,b,s:Integer;
begin
Read(a,b);
if(a<0) and (b<0) then
a:= abs(a);
for var n:= 1 to abs(b) do
s+=a;
WriteLn(s);
end.
2)
var a,s:Integer;
begin
Read(a);
for var n:= 1 to a do
s+=n;
WriteLn(s);
end.
3)
var a,b,s:Integer;
begin
Read(a,b);
for var n:=a to b do
s+=n*n;
WriteLn(s);
end.
4)
var a,b,n:Integer;
begin
Randomize;
Read(a,b,n);
for var q:=1 to n do
Write(Random (b+1-a)+a+' ');
end.
var a,b,s:Integer;
begin
Read(a,b);
if(a<0) and (b<0) then
a:= abs(a);
for var n:= 1 to abs(b) do
s+=a;
WriteLn(s);
end.
2)
var a,s:Integer;
begin
Read(a);
for var n:= 1 to a do
s+=n;
WriteLn(s);
end.
3)
var a,b,s:Integer;
begin
Read(a,b);
for var n:=a to b do
s+=n*n;
WriteLn(s);
end.
4)
var a,b,n:Integer;
begin
Randomize;
Read(a,b,n);
for var q:=1 to n do
Write(Random (b+1-a)+a+' ');
end.
Ответил petyaGavrikov
0
Проверьте в задаче 1) 15 и -7.
Ответил ruslol
0
Спасибо.Сейчас исправлю
Новые вопросы
Математика,
8 лет назад
Математика,
9 лет назад