1) Напишите программу, которая с помощью цикла подсчитывает сумму всех четных чисел от 5 до 25. Можете подсказать, где здесь ошибка?
#include
using namespace std;
void chislo (int i, int summa=0)
{
if (i%2==0)
{
summa=summa+i;
}
}
int main ()
{
int i=5; i<=25; i++;
int summa;
cout<<"summa vseh chetnih chisel="< return 0;
}
akmaamir:
в последнем cout<<"summa vseh chetnih chisel="<
Ответы на вопрос
Ответил Mydrec12
0
Ответ:
#include <stdio.h>
#include <iostream>
using namespace std;
int main()
{
int summa=0;
for (int i = 5; i <= 25; i++)
{
if(i % 2 == 0)
{
summa= summa+i;
}
}
std::cout <<"Сумма всех чётных чисел="<<summa;
}
Объяснение:
Зачем ты использовал void?)
while (i<=25)
{
if(i % 2 == 0)
{
summa= summa+i;
}
++i;
}
Ответил restIess
1
У тебя вообще нет понимания, что такое функция.
Верный код:
#include <iostream>
using namespace std;
void SumChet(){
int s = 0;
for (int i = 6; i < 25; i += 2)
s += i;
cout << "Сумма четных от 5 до 25: " << s;
}
signed main()
{
SumChet();
return 0;
}
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Английский язык,
2 года назад
Литература,
2 года назад
История,
8 лет назад