1. Напишите программу, которая при введении порядко
вого номера пальца руки выводит его название на экране.
Ответы на вопрос
C#
int a;
ConsoleKeyInfo keyInfo;
do
{
Console.WriteLine("Введении один порядковый номера пальца руки:\n1, 2, 3, 4, 5");
a = Convert.ToInt32(Console.ReadLine());
switch (a)
{
case 1:
Console.WriteLine("Большой\n");
break;
case 2:
Console.WriteLine("Указательный\n");
break;
case 3:
Console.WriteLine("Средний\n");
break;
case 4:
Console.WriteLine("Безымянный\n");
break;
case 5:
Console.WriteLine("Мизинец\n");
break;
default:
Console.WriteLine("Такого пальца нет\n");
break;
}
Console.WriteLine("Если хотите повторить программу нажмите F");
Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");
keyInfo = Console.ReadKey(true);
}
while (keyInfo.Key == ConsoleKey.F);
