Информатика, вопрос задал sihelob264 , 7 лет назад

1. Напишите программу, которая получает с клавиатуры четыре целых числа и находит наибольшее и наименьшее из них.
2. Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит сообщение «По росту.», если числа введены по возрастанию (неубыванию), или сообщение «Не по росту!», если они введены в другом порядке.
3. Напишите программу, которая получает с клавиатуры номер месяца и выводит название соответствующего ему времени года или сообщение об ошибке.
4. Напишите программу, которая получает с клавиатуры целое число и выводит ответ на вопрос: «Верно ли, что было получено трёхзначное число?».
5. Напишите программу, которая получает с клавиатуры трёхзначное число и выводит ответ на вопрос: «Верно ли, что введённое число – палиндром?» (число-палиндром читается одинаково слева направо и справа налево, например, число 151).
python

Ответы на вопрос

Ответил Аноним
0

1)

number_list = []

for i in range(4):

   number_list.append(int(input()))

print('максимальное число: ' + str(max(number_list)))

print('минимальное число: ' + str(min(number_list)))

2)

first_list = [int(input()) for n in range(3)]

second_list = []

for number in first_list:

   second_list.append(number)

first_list.sort()

if first_list == second_list:

   print('по росту .')

else:

   print('не по росту !')

3)

month_ask = str(input())

if month_ask in ['12', '1', '2', '01', '02']:

   print('Зима .')

elif month_ask in ['3', '4', '5', '03', '04', '05']:

   print('Весна .')

elif month_ask in ['6', '7', '8', '06', '07', '08']:

   print('Лето .')

elif month_ask in ['9', '10', '11', '09']:

   print('Осень .')

4)

number = str(input())

if len(number) == 3:

   print('Верно .')

else:

   print('Не верно .')

5)

number = str(input())

first_list = []

for n in number:

   first_list.append(n)

second_list = []

for i in first_list:

   second_list.append(i)

first_list.reverse()

print(first_list)

print(second_list)

if first_list == second_list:

   print('Верно .')

else:

   print('Не верно')

Новые вопросы