Информатика, вопрос задал abekdauletov , 2 года назад

1)Напишите программу, которая переводит цифровую систему отметок в словесную. Например если пользователь ввел оценку "5", на экран выводится словесная отметка "Пятерка"
2)Напишите альтернативную программу с применением оператора if для 1-ой задачи


pinguinbird: на каком языке писать?

Ответы на вопрос

Ответил edik1975
2

Ответ:

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

case i of  

1: writeln('Единица');  

2: writeln('Двойка');  

3: writeln('Тройка');  

4: writeln('Четверка');  

5: writeln('Пятерка');  

else writeln('Нет такой оценки');  

end;  

readln;  

end.

Альтернативная задача

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

if i = 1 then writeln('Единица')

else if i = 2 then writeln('Двойка')

else if i = 3 then writeln('Тройка')

else if i = 4 then writeln('Четверка')

else if i = 5 then writeln('Пятерка')

else writeln('Нет такой оценки');    

readln;  

end.

Объяснение:

Новые вопросы