1. Напишите программу, которая находит наименьшее из чисел, крат¬ных трём в последовательности целых чисел. Гарантируется, что в после¬довательности есть хотя бы одно такое число. Программа получает на вход целые числа, количество введённых чисел неизвестно, последова¬тельность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: наименьшее из чисел, кратных. Пример работы программы: Входные данные Выходные данные 12 3 15 2 3 6 0
Ответы на вопрос
Ответил ИнформатикБУ
0
var
a, min: integer;
begin
min :=30000;
repeat
readln(a);
if (a mod 3 = 0) and (a < min) and (a <> 0) then
min := a;
until a = 0;
writeln(min);
end.
a, min: integer;
begin
min :=30000;
repeat
readln(a);
if (a mod 3 = 0) and (a < min) and (a <> 0) then
min := a;
until a = 0;
writeln(min);
end.
Новые вопросы
История,
2 года назад
Английский язык,
2 года назад
Математика,
9 лет назад
Литература,
9 лет назад
Математика,
9 лет назад