Информатика, вопрос задал rgermekhanova , 1 год назад

1. Напишите программу, которая читает с клавиатуры натуральное число N, повторяет его 5 раз и возводит в третью степень. Пример: N = 1. Вывести 1 371 700 960 631 ( = 111119)
2. Q учеников пытаются поделить W задач поровну между собой (Q, W - натуральные числа). Сколько задач достанется каждому из них? Сколько задач не получится распределить? Пример: 3 ученика делят между собой 7 задач. Каждому достанется по 2 задачи, одна задача останется нераспределенной.
3. Дано натуральное число N, N>10. Выведите его последнюю и предпоследнюю цифры. Пример: С клавиатуры вводится 12345, требуется вывести 4 5


pgjfhfshvdjds: Здравствуйте. Сколько вам лет?
rgermekhanova: 13
rgermekhanova: Пожалуйста помогите
WHAAAAAAAAAAAGH: Какой язык использовать?
rgermekhanova: Python

Ответы на вопрос

Ответил Chichivara228
2

Ответ:

Объяснение:

Решал на Python 3.10:

1)

N = input()

print(int(N * 5) ** 3)

2)

Q = int(input())

W = int(input())

print(f"Каждому достанется по {W // Q} задач.")

print(f"{W % Q} задач останутся нераспределенными.")

3)

N = input()

print(f'{N[-2]} {N[-1]}')

Приложения:

rgermekhanova: Спасибо
Ответил DK404
0

Ответ:

1.

n = (int(input()*5))**3

print(n)

2.

q, w = map(int,input().split())

exs = w//q

exs_uncompl = w-q*exs

print(exs,exs_uncompl)

3.

n = input()

c = 0

for num in n:

    c += 1

print(n[c-2:])

Comment:

Надіюся що допомогла, якщо треба можеш звертатися, та якщо треба то у телеграм @DK50503.


DK404: Пока писала вже втигли вiдповiсти, хех
Chichivara228: У вас в первом немного неправильно выйдет. По условию требуется повторить введенную цифру N 5 раз и потом полученное число возвести в 3 степень. То есть, допустим N = 1: 11111 ** 3 = 1370....
DK404: А, ой, не поняла когда читала условие в каком смысле повторить введенную цифру 5 раз. Исправила
Новые вопросы