1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел
Ответы на вопрос
Ответил HRAshton
0
var a: array [1..5, 1..5] of integer;
i, m, j: integer;
begin
for i := 1 to 5 do
for j := 1 to 5 do
begin
a[i, j] := random(50) - 25;
writeln('[', i, ',', j, '] => ', a[i, j]);
end;
for i := 1 to 5 do
for j := 1 to 5 do
if (a[i, j] mod 2 = 0) then a[i, j] := 30;
writeln();
for i := 1 to 5 do
for j := 1 to 5 do
writeln('[', i, ',', j, '] => ', a[i, j]);
end.
Для второго не понял, как решать ._.
i, m, j: integer;
begin
for i := 1 to 5 do
for j := 1 to 5 do
begin
a[i, j] := random(50) - 25;
writeln('[', i, ',', j, '] => ', a[i, j]);
end;
for i := 1 to 5 do
for j := 1 to 5 do
if (a[i, j] mod 2 = 0) then a[i, j] := 30;
writeln();
for i := 1 to 5 do
for j := 1 to 5 do
writeln('[', i, ',', j, '] => ', a[i, j]);
end.
Для второго не понял, как решать ._.
Ответил HRAshton
0
Сумма индексов главной диагонали, но я вот думаю: 15 или 30?.. Вообще-то, наверное, 30, исправил ._. А вообще это потому, что считать в цикле нерационально это =)
Новые вопросы