1. Напиши программу, которая меняет местами содержимое переменных а и b так, чтобы в переменной а всегда было большее значение. Вставь три пропущенные строки в правильном порядке (фотография)
2. Напиши программу, которая запрашивает с клавиатуры 2 числа и находит их сумму, если оба они чётные, в противном случае находит их произведение.
3. Напишите программу, которая запрашивает с клавиатуры 2 числа и находит их сумму, если одно из них чётное, в противном случае, находит их произведение.
Приложения:

Ответы на вопрос
Ответил korsa351
2
1)
var
a,b,c:integer;
begin
readln(a,b);
if a < b then begin
c:=a;
a:=b;
b:=c;
end;
writeln(a, ' ', b);
end.
2)
var
a,b:integer;
begin
readln(a,b);
if Odd(a) and Odd(b) then writeln(a*b)
else writeln(a+b);
end.
3)
var
a,b:integer;
begin
readln(a,b);
if not Odd(a) or not Odd(b) then writeln(a+b)
else writeln(a*b);
end.
Приложения:



Новые вопросы
Алгебра,
2 года назад
Геометрия,
2 года назад
Қазақ тiлi,
7 лет назад
Английский язык,
7 лет назад
История,
8 лет назад